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COMSOL AC/DC MODULE 3.5a 

2D-расчет электрического 
генератора. 
ɺʚʝʜʝʥʠʝ 

В данном примере демонстрируется процесс наведения ЭДС в статорной обмотке генератора в 

результате вращения ротора с постоянными магнитами. Наведенная ЭДС вычисляется как 

функция времени. Также показано влияние на результат свойств материала, скорости вращения и 

количества витков в обмотке.  

Центральная часть ротора выполнена из среднеуглеродистой стали, обладающей высокой 

магнитной проницаемостью. По периметру расположены постоянные магниты (SmCo), создающие 

сильное магнитное поле. Статор выполнен из того же материала что и центральная часть ротора. 

Обмотка намотана вокруг полюсов статора и расположена в пазах. Вся конструкция показана на 

рисунке ниже (фрагмент статора не показан).   

 

ʈʝʘʣʠʟʘʮʠʷ ʚ COMSOL Multiphysics 

Модель генератора в рассматриваемой постановке представляет собой двумерную задачу расчета  

переменного во времени магнитного поля в поперечном сечении генератора. В задаче 

учитываются динамические эффекты возникающие в результате движения источников магнитного 

поля (роторных магнитов) относительно обмоток статора. Движение ротора относительно статора 

учитывается через граничные условия в зазоре, т.е. член (σ v × B) в уравнении отсутствует:  

 

где вектор магнитного потенциала имеет только z-͔ͦͣͨͦͤͤͭͯ͟. 
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Вращение моделируется с использованием технологии деформируемой сетки (ALE), при этом 

центральная часть геометрической модели, состоящая из ротора и части воздушного зазора, 

вращается относительно статора. Вращение сетки задается уравнением трансформации: 

 

Ротор и статор выполняются как два раздельных геометрических объекта, поэтому можно 

воспользоваться сборкой (см. “Using Assemblies” стр. 405 COMSOL Multiphysics  Modeling  Guide ). Это 

дает несколько преимуществ: связь между ротором и статором осуществляется автоматически, 

сетки объектов входящих в сборку не связаны, допускается разрыв векторного потенциала на 

стыках между такими объектами. Ротор решается во вращающейся системе координат 

неподвижной относительно ротора, а статор в неподвижной глобальной системе координат. 

Интерполяционные уравнения связи на границе моделей обеспечивают непрерывность решения в 

глобальной системе координат, связанной со статором.  

Материал статора и центральной части ротора обладает нелинейной зависимостью магнитной 

индукции от напряженности магнитного поля  - кривая B-H. В COMSOL Multiphysics кривые B-H 

представляют собой интерполяционные функции, заданные по точкам (см. рис. ниже). Функция 

может быть использована в пределах подобласти, обычно кривые В-Н определены как функция 

|B| от |H|. Материал Soft Iron (without losses) с уже заданной кривой присутствует в 

стандартной библиотеке материалов acdc_lib.txt, поставляемой с модулем AC/DC. 
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Генерируемое напряжение вычисляется как линейный интеграл напряженности электрического 

поля E  вдоль обмотки. Поскольку секции обмоток не соединены в двумерном анализе, в явном 

виде такой интеграл вычислить нельзя. В простом приближении можно пренебречь падением 

напряжения на лобовых частях обмотки. В этом случае напряжение может быть вычислено как 

сумма средних значений z компоненты электрического поля E , вычисленных по сечению каждой 

обмотки, умноженных на длину участка обмотки в статоре.  

 

гдe - L  длина статора в направлении оси,  NN  - количество витков обмотки, A - площадь сечения 

обмотки.  

 

ʈʝʟʫʣʴʪʘʪʳ 

Генерируемое напряжение холостого хода в статорной обмотке по форме близко к 

синусоидальному. При скорости вращения ротора 60 оборотов в минуту амплитуда напряжения 

составила 2.3В для одновитковой обмотки. Форма напряжения представлена на рис. ниже. 

 

Модуль магнитной индукции и силовые линии поля для момента времени t=0.2c показаны на рис. 

ниже.  
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Уже выполненный проект с описанной задачей может быть загружен при запуске программы из 

MPH- файла. В окне Model Navigator необходимо выбрать закладку Model Library и далее 

выбрать проект ACDC_Module / Motors _and_Drives / generator _2d 

 

ʈʝʰʝʥʠʝ ʩ ʠʩʧʦʣʴʟʦʚʘʥʠʝʤ ʛʨʘʬʠʯʝʩʢʦʛʦ ʠʥʪʝʨʬʝʡʩʘ. 

 

НАВИГАТОР МОДЕЛЕЙ  

1  Запустите Model Navigator (ȳɆɈɎɉɆɘɔɖ ɒɔɊɋɑɋɏ) и выберите 2D в списке Space dimension 

(ȶɆɍɒɋɖɓɔɗɘɢ). 

2  В папке AC/DC Module выберите пункт Rotating Machinery ( ȨɖɆɟɆɤɟɎɋɗɥ ɒɆɞɎɓɡ)  > 

Rotating Perpendicular Currents. 

3  Нажмите OK. 

 

НАСТРОЙКА, ОПИСАНИЕ ПАРАМЕТРОВ 

1  В меню Options (ȴɕɜɎɎ),  выберите Constants (ȰɔɓɗɘɆɓɘɡ). 

2  В появившемся окне Constants заполните поля таблицы Name ( Ȯɒɥ ɕɆɖɆɒɋɘɖɆ) , 

Expression ( ȨɡɖɆɌɋɓɎɋ)  и по желанию Description ( ȴɕɎɗɆɓɎɋ)  как показано ниже 

(допускается вводить описание кириллицей): 
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NAME EXPRESSION DESCRIPTION 

t  0[s]  Time for stationary solution  ( ʚʨʝʤʷ ʜʣʷ ʩʪʘʮʠʦʥʘʨʥʦʛʦ 

ʨʝʰʝʥʠʷ)  

rpm 60[1/min]  Revolutions per minute  ( ʩʢʦʨʦʩʪʴ ʚʨʘʱʝʥʠʷ)  

A pi*(0.02[m])^2  Area of wires in the stator  ( ʧʣʦʱʘʜʴ ʩʝʯʝʥʠʷ ʚʠʪʢʦʚ 

ʩʪʘʪʦʨʥʦʡ ʦʙʤʦʪʢʠ)  

L 0.4[m]  Length of the generator  ( ʜʣʠʥʘ ʛʝʥʝʨʘʪʦʨʘ)  

NN 1 Number of turns in stator winding  ( ʢʦʣʠʯʝʩʪʚʦ ʚʠʪʢʦʚ ʚ 

ʦʙʤʦʪʢʝ)  

После ввода константы t цвет текста поменяется на красный, т.к. t - зарезервированное имя 

переменной в in COMSOL Multiphysics. Вначале необходимо выполнить статический расчет, 

результаты которого в дальнейшем будут использованы в качестве начальных условий для 

динамического расчета. Поэтому на данном этапе переменной t следует присвоить значение 0. 

ПОСТРОЕНИЕ ГЕОМЕТРИИ 

Геометрическая модель может быть построена посредством редактора, встроенного в COMSOL 

Multiphysics или импортирована из библиотеки готовых примеров.  

ʀʤʧʦʨʪ ʛʝʦʤʝʪʨʠʠ ʠʟ ʙʠʥʘʨʥʦʛʦ ʬʘʡʣʘ 

1  В меню File выберите Import>CAD Data From File. 

2  Убедитесь, что в строке Files of type выбрано All 2D CAD files или COMSOL Multiphysics file. 

3  В установочной директории COMSOL Multiphysics откройте папку 

ACDC_Module / Motors _and_Drives / generator _2d, выберите файл 

generator_2d.mphbin  и нажмите Import. 

4  Пропустите раздел "Построение геометрии" и продолжите работу с раздела "Сборка геометрии" 

 

ʇʦʩʪʨʦʝʥʠʝ ʛʝʦʤʝʪʨʠʠ 

Аккуратно следуйте инструкции по созданию геометрии. Получившаяся нумерация объектов будет 

использована на последующих этапах решения задачи. После всех операций модель должна 

содержать 152 границы.  

1  Выберите Draw>Specify Objects>Circle (ȳɆɖɎɗɔɈɆɘɢ > ȷɔɍɊɆɘɢ ɔɇɠɋɐɘ > ȴɐɖəɌɓɔɗɘɢ) 

чтобы создать окружности со следующими параметрами: 

NAME  (ʀʄʗ) RADIUS (ʈɸɼʀʋʉ) BASE (ɹɸɿɸ) X Y ROTATION ANGLE  (ʋɻʆʃ ʇʆɺʆʈʆʊɸ) 

C1 0.3  Center 0 0 22.5  

C2 0.235  Center 0 0 0 

C3 0.225  Center 0 0 0 

C4 0.4  Center 0 0 0 
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2  Выберите Draw>Specify Objects>Rectangle (ȳɆɖɎɗɔɈɆɘɢ > ȷɔɍɊɆɘɢ ɔɇɠɋɐɘ > 

ȵɖɥɒɔəɉɔɑɢɓɎɐ) чтобы создать прямоугольники со следующими параметрами: 

NAME  (ʀʄʗ) WIDTH  

(ʐʀʈʀʅɸ) 

HEIGHT  

(ɺʓʉʆʊɸ) 

BASE (ɹɸɿɸ) X Y ROTATION ANGLE  (ʋɻʆʃ 

ʇʆɺʆʈʆʊɸ) 

R1 0.1  1 Center 0 0 0 

R2 0.1  1 Center 0 0 45 

R3 0.1  1 Center 0 0 90 

R4 0.1  1 Center 0 0 135  

3  Откройте окно Create Composite Object (ȷɔɍɊɆɘɢ ɐɔɒɇɎɓɎɖɔɈɆɓɓɡɏ ɔɇɠɋɐɘ)  в меню 

Draw или нажмите соответствующую иконку в панели инструментов. 

4  Деактивируйте опцию Keep interior boundaries (ȷɔɛɖɆɓɥɘɢ ɈɓəɘɖɋɓɓɎɋ ɉɖɆɓɎɜɡ). 

5  Введите C2+C1*( R1+R2+R3+R4)  в поле Set formula (ȭɆɊɆɘɢ ɚɔɖɒəɑə). 

6  Нажмите OK. 

7  Откройте Create Composite Object, активируйте опцию Keep interior boundaries. 

8  Введите C4+CO1- C3 в поле Set formula. 

9  Нажмите OK. 

10  Создайте две новые окружности с параметрами, указанными в таблице:  

NAME  RADIUS BASE X Y ROTATION  ANGLE  

C1 0.015  Center 0.025  0.275  0 

C2 0.015  Center - 0.025  0.275  0 

11  Нажмите кнопку Zoom Extents чтобы отобразить геометрию на весь экран. 

12  Выберите окружности C1 и C2. 

13  Нажмите Ctrl+C чтобы скопировать окружности в буфер. 

14  Нажмите Ctrl+V чтобы вставить копии окружностей в модель. Убедитесь, что указаны нулевые 

перемещения, нажмите OK. 

15  Выберите Draw > Modify > Rotate (ȳɆɖɎɗɔɈɆɘɢ > ȮɍɒɋɓɎɘɢ > ȵɔɈɋɖɓəɘɢ) введите 45 в 

поле Rotation angle (ȹɉɔɑ ɕɔɈɔɖɔɘɆ). Нажмите OK. 

16  Повторите два последних шага с углами поворота 90, 135, 180, ī45, ī90 и ī135. 

17  Выберите все объекты нажав Ctrl+A, затем нажмите кнопу Union (ȴɇɠɋɊɎɓɎɘɢ) в панели 

инструментов.  

18  Создайте четыре окружности со следующими параметрами: 

NAME  RADIUS BASE X Y ROTATION ANGLE  

C1 0.215  Center 0 0 0 

C2 0.15  Center 0 0 22.5  
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C3 0.15  Center 0 0 22.5  

C4 0.225  Center 0 0 0 

19  Создайте четыре прямоугольника со следующими параметрами: 

NAME  WIDTH  HEIGHT  BASE X Y ROTATION ANGLE  

R1 0.1  1 Center 0 0 22.5  

R2 0.1  1 Center 0 0 - 22.5  

R3 0.1  1 Center 0 0 67.5  

R4 0.1  1 Center 0 0 - 67.5  

20  Откройте окно Create Composite Object в меню Draw и деактивируйте опцию Keep interior 

boundaries. 

21  Введите C2+C1*(R1+R2+R3+R4)  в поле Set formula. 

22  Нажмите OK. 

23  Откройте Create Composite Object, активируйте опцию Keep interior boundaries. 

24  Введите CO2+C3+C4 в поле Set formula. 

25  Нажмите OK. 

Геометрия должна выглядеть следующим образом: 
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ʉʙʦʨʢʘ 

1  Откройте окно Create Pairs (ȷɔɍɊɆɘɢ ɕɆɖɡ) в меню Draw. 

2  Выберите оба объекта (CO1 и CO3), нажмите OK. 

 

Теперь два отдельных объекта объединены в сборку. Также были заданы граничные условия, 

обеспечивающие непрерывность решения на границе ротор-статор при том, что с точки зрения 

построения сетки объекты остались несвязанными. 

ФИЗИЧЕСКАЯ ЧАСТЬ ПОСТАНОВКИ ЗАДАЧИ 

1  В меню выберите Options > Integration Coupling Variables > Subdomain Variables. 

( ȴɕɜɎɎ > ȷɔɈɒɋɗɘɓɡɋ ɎɓɘɋɉɖɆɑɢɓɡɋ ɕɋɖɋɒɋɓɓɡɋ > ȵɋɖɋɒɋɓɓɡɋ ɕɔɊɔɇɑɆɗɘɋɏ)  

2  В окне Subdomain Integration Variables задайте переменную с четвертым порядком 

интегрирования в соответствии со таблицей:  

NAME  

(ʀʄʗ) 

EXPRESSION IN SUBDOMAINS 5ï8, 13ï16 

(ɺʓʈɸɾɽʅʀʗ ɼʃʗ ʇʆɼʆɹʃɸʉʊɽʁ 5ï8, 13ï16) 

EXPRESSION IN SUBDOMAINS 3, 4, 9ï12, 17, 18 

(ɺʓʈɸɾɽʅʀʗ ɼʃʗ ʇʆɼʆɹʃɸʉʊɽʁ 3, 4, 9ï12, 17, 18) 

Vi  - L*Ez_emqa/A  L*Ez_emqa/A  

3  Нажмите OK. 

 

Пункты 4-6 необходимы только для того чтобы убедиться, что необходимые библиотеки загружены 

и чтобы увидеть интерполяционную функцию для одного из материалов. Эти шаги можно 

пропустить, если Вы уверены, что библиотеки загружены. Если в последствии выяснится, что 

библиотеки не загружены просто выполните эти три пункта.  

4  Откройте в меню Options > Materials/Coefficients Library ( ȴɕɜɎɎ > ȧɎɇɑɎɔɘɋɐɆ 

ɒɆɘɖɎɆɑɔɈ/ ɐɔɣɚɚɎɜɎɋɓɘɔɈ)  

5  Убедитесь, что библиотека acdc _lib . txt  загружена (кликните на знак "-" напротив других 

библиотек, чтобы скрыть их содержимое). Если библиотеки нет, загрузите ее нажав на 

кнопку Add Library (ȪɔɇɆɈɎɘɢ ɇɎɇɑɎɔɘɋɐə). Файл должен находиться в папке "data" в 

установочной директории COMSOL. 

6  Нажмите ȴȰ. 

 

ʇʘʨʘʤʝʪʨʳ ʧʦʜʦʙʣʘʩʪʝʡ. 

1  Выберите в меню Multiphysics > Perpendicular Induction Currents, Vector Potential 

(emqa) 

2  Выберите Physics>Properties. 

3  В открывшемся окне установите On для Weak constraints (ȷɑɆɇɡɋ ɔɉɖɆɓɎɝɋɓɎɥ) . Это 

условие помогает выполнить условие передачи потока через границу между ротором и 

статором. Это позволяет задать абсолютную погрешность для этого параметра при 

моделировании динамических процессов.  

4  Click OK. 
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5  В меню откройте Physics>Subdomain Settings и выберите любую подобласть в списке 

Subdomain selection. 

6  Нажмите Load чтобы открыть окно Materials/Coefficients Library. 

7  Выберите Soft Iron (without losses) (ȲɆɉɓɎɘɔɒɥɉɔɋ Ɍɋɑɋɍɔ (ɇɋɍ ɕɔɘɋɖɢ)) в библиотеке 

Electric (AC/DC) Material Properties. 

8  Click Apply. The material Soft Iron (without losses) has now been added to the model. You see 

which materials you have added to the model under the Model item in the Materials tree view. 

Нажмите Apply. Материал Soft Iron (without losses) добавлен в модель. Список материалов, 

добавленных в модель можно посмотреть в разделе Model. 

9  Повторите последние два действия для материалов Samarium Cobalt (Radial, inward) 

(ȷɆɒɆɖɎɏ-ȰɔɇɆɑɢɘ (ȶɆɊɎɆɑɢɓɔ ɓɆɒɆɉɓɎɝɋɓɓɡɏ ɐ ɜɋɓɘɖə))  и Samarium Cobalt (Radial, 

outward) (ȷɆɒɆɖɎɏ-ȰɔɇɆɑɢɘ (ȶɆɊɎɆɑɢɓɔ ɓɆɒɆɉɓɎɝɋɓɓɡɏ ɔɘ ɜɋɓɘɖɆ) ) . 

10  Click Cancel to close the Materials/Coefficients Library dialog box. 

Нажмите Cancel чтобы закрыть окно. 

11  Введите свойства подобластей и выберите материалы в соответствии с таблицей ниже. 

Начинайте выбор с Constitutive relation (ȴɕɖɋɊɋɑɥɤɟɆɥ ɍɆɈɎɗɎɒɔɗɘɢ). 

 

SETTINGS SUBDOMAINS 

20, 23, 24, 27 

SUBDOMAINS 

21, 22, 25, 26 

SUBDOMAINS 2, 28 ALL OTHER 

SUBDOMAINS 

B  ź H  B  = ɛ
0
ɛ

r
H  + B

r
 B  = ɛ

0
ɛ

r
H  + B

r
 H  = f(|B |)e

B
 B  = ɛ

0
ɛ

r
H  

Library material Samarium Cobalt 

(Radial, inward) 

Samarium Cobalt 

(Radial, outward) 

Soft Iron (without 

losses) 

 

12  Нажмите OK. 

13  Выберите  в меню Multiphysics > Moving Mesh (ALE) (ale). 

14  Выберите Physics > Subdomain Settings. 

15  В списке выберите подобласти 19–28, в списке Group выберите rotate_CCW (ɈɖɆɟɋɓɎɋ 

ɕɖɔɘɎɈ ɝɆɗɔɈɔɏ ɗɘɖɋɑɐɎ). 
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Для этой группы используются готовые выражения, описывающие вращение против часовой 

стрелки относительно начала координат. Для остальных подобластей оставьте группу по 

умолчанию, без перемещений.  

16  Нажмите ȴȰ. 

 

ɻʨʘʥʠʯʥʳʝ ʫʩʣʦʚʠʷ. 

Оставьте граничные условия, заданные по умолчанию. Граничные условия, заданные в пункте 

"Сборка" обеспечат непрерывность решения на границе ротор-статор. 

ГЕНЕРАЦИЯ СЕТКИ 

1  Выберите в меню Mesh>Free Mesh Parameters (ȷɋɘɐɆ>ȵɆɖɆɒɋɘɖɡ ɗɈɔɇɔɊɓɔɉɔ 

ɖɆɍɇɎɋɓɎɥ) 

2  В списке Predefined mesh sizes ( ȵɖɋɊɔɕɖɋɊɋɑɋɓɓɡɏ ɖɆɍɒɋɖ ɣɑɋɒɋɓɘɔɈ) выберите Finer 

(ȳɎɌɋ ɗɖɋɊɓɋɉɔ) 

3  Включите опцию Custom mesh size (ȭɆɊɆɘɢ ɖɆɍɒɋɖɡ Ɉɖəɝɓəɤ) и введите 2 в поле 

Resolution of narrow regions (ȶɆɍɖɋɞɋɓɎɋ Ɉ əɍɐɎɛ ɔɇɑɆɗɘɥɛ). 

4  Нажмите Remesh для построения сетки. 

5  Нажмите OK чтобы закрыть окно. 

 

РЕШЕНИЕ 

Начнем с решения статической задачи, результаты которой послужат начальным условием при 

решении динамической. 

1  Откройте окно Solver Parameters (ȵɆɖɆɒɋɘɖɡ ɖɋɞɆɘɋɑɥ) в меню Solve или нажав 

соответствующую кнопку в панели инструментов. 

2  В списке Analysis (ȸɎɕ ɆɓɆɑɎɍɆ) выберите  Static (ȷɘɆɘɎɝɋɗɐɎɏ), активируйте опцию Auto 

select solver (ȦɈɘɔɒɆɘɎɝɋɗɐɎɏ Ɉɡɇɔɖ ɖɋɞɆɘɋɑɥ). 

3  Нажмите OK. 

4  Нажмите Solve ( ȶɋɞɎɘɢ). 

Теперь решим задачу с вращением ротора. По умолчанию решение полученное на предыдущем 

этапе послужит начальным условием. 

1  Откройте окно Solver Parameters и выберите тип анализа Transient (ȵɋɖɋɛɔɊɓɡɏ 

ɕɖɔɜɋɗɗ). 

2  В поле Times ( Ȩɖɋɒɥ)  введите range (0,0.01,0.25) , в поле Absolute tolerance 

( ȦɇɗɔɑɤɘɓɆɥ ɕɔɉɖɋɞɓɔɗɘɢ)  введите Az 1e- 3 lm 1 5 e3. 
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3  Нажмите OK. 

4  Нажмите Restart. 

 

ОБРАБОТКА И ВИЗУАЛИЗАЦИЯ РЕЗУЛЬТАТОВ 

1  Выберите в меню Postprocessing > Plot Parameters 

2  В закладке General  (ȴɇɟɋɋ) в списке Solution  at  time  (ȶɋɞɋɓɎɋ ɓɆ ɒɔɒɋɓɘ ɈɖɋɒɋɓɎ) 

выберите решение для момента временит 0.2сек. 

3  В закладке Surface ( ȵɔɈɋɖɛɓɔɗɘɓɔɋ)  в списке Predefined quantities ( ȵɖɋɊɔɕɖɋɊɋɑɋɓɓɡɋ 

ɈɋɑɎɝɎɓɡ) выберите Magnetic flux density ( ȲɆɉɓɎɘɓɆɥ ɎɓɊəɐɜɎɥ)  или введите 

normB_emqa в поле Expression ( ȨɡɖɆɌɋɓɎɋ) . 

4  В закладке Contour (Ȱɔɓɘəɖɓɔɋ) в поле Expression введите Az, в поле Levels (ȹɖɔɈɓɎ) 

введите 15. Активируйте опцию Contour plot (Ȱɔɓɘəɖɓɔɋ ɔɘɔɇɖɆɌɋɓɎɋ). 

5  В этой же закладке в разделе Contour color (ȼɈɋɘ ɐɔɓɘəɖɔɈ) выберите Uniform color 

(ȴɊɓɔɘɔɓɓɡɏ) и отключите опцию Color legend ( ȼɈɋɘɔɈɆɥ ɑɋɉɋɓɊɆ). 

6  Нажмите кнопку Color и выберите черный цвет. Нажмите OK чтобы закрыть окно Contour 

Color. 

7  В закладке Boundary (ȩɖɆɓɎɝɓɔɋ) введите 1 в поле Expression. Включите опцию Boundary 

plot (ȩɖɆɓɎɝɓɔɋ ɔɘɔɇɖɆɌɋɓɎɋ). 

8  В разделе Boundary color включите опцию Uniform color. 

9  Нажмите кнопку Color и выберите черный цвет. Нажмите OK чтобы закрыть окно Boundary 

Color. 
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10  Нажмите OK чтобы закрыть окно Plot Parameters. 

 

 

Выполните следующие шаги, чтобы посмотреть зависимость наведенного напряжения от времени. 

1  Выберите Postprocessing > Domain Plot Parameters ( ȵɔɗɘɕɖɔɜɋɗɗɔɖ> ȴɘɔɇɖɆɍɎɘɢ 

ɕɆɖɆɒɋɘɖɡ Ɋɑɥ ɔɇɑɆɗɘɋɏ)  

2  В закладке Point в списке Point selection выберите произвольную точку и введите 

выражение Vi * NN в поле Expression. 

3  Нажмите OK. 

 

Выполните следующие шаги для создания анимационного ролика с вращением ротора. 

1  Откройте окно Plot Parameters. 

2  Выберите закладку Animate, убедитесь, что выбраны все временные шаги. 

3  Нажмите кнопку Start Animation. Когда ролик будет создан автоматически запустится 

встроенный проигрыватель COMSOL Movie  Player . 

 

 


